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Document Conventions
In addition to the use of italics for names of documents, the font conventions that are used in
this document are summarized in the table below.

Links to other locations in the current document or to other PDF documents are colored like
this: Document Conventions.

In descriptions of command syntax, the following UNIX conventions are used: braces { }

enclose a choice of required items, square brackets [ ] enclose optional items, and the bar
symbol | separates items in a list from which one item must be chosen. Lines of command
syntax that wrap should be interpreted as a single command.

File name, path, and environment variable syntax is generally given with the UNIX conven-
tions. To obtain the Windows conventions, replace the forward slash / with the backslash \ in
path or directory names, and replace the $ at the beginning of an environment variable with a
% at each end. For example, $SCHRODINGER/maestro becomes %SCHRODINGER%\maestro.

In this document, to type text means to type the required text in the specified location, and to
enter text means to type the required text, then press the ENTER key.

References to literature sources are given in square brackets, like this: [10].

Font Example Use

Sans serif Project Table Names of GUI features, such as panels, menus,
menu items, buttons, and labels

Monospace $SCHRODINGER/maestro File names, directory names, commands, envi-
ronment variables, and screen output

Italic filename Text that the user must replace with a value

Sans serif
uppercase

CTRL+H Keyboard keys
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Chapter 1
Chapter 1: Getting Started
1.1 About MacroModel

MacroModel 9.7 is a general purpose, force-field-based molecular modeling program with
applicability to a wide range of chemical systems. MacroModel provides multiple advanced
methods to aid in the understanding of chemical structure, energetics, and dynamics. A large
selection of force fields is included, along with the latest technical advances introduced into the
OPLS force fields. Numerous minimization methods are available, enabling geometry optimi-
zations for a broad selection of structural classes. A wide range of methods is available for
conformational searching, which allows efficient sampling of the potential energy surface for
low-energy structures, including entire proteins. Solvation effects can be accounted for using
the efficient continuum solvation model in MacroModel. Additional advanced features include
molecular dynamics simulations, free-energy perturbation simulations, and pure- and mixed-
ensemble sampling methods.

1.2 About this Manual

This manual contains exercises designed to help you learn the basic tasks for preparing and
initiating MacroModel calculations from Maestro. Once you have worked through these exer-
cises, you will have an understanding of the basic MacroModel features. The exercises are
divided into groups:

• Chapter 2 contains exercises on a number of basic operations in Maestro.
• Chapter 3 contains exercises on the calculation and minimization of the energy.
• Chapter 4 contains exercises on conformational searching.
• Chapter 5 contains exercises on various other MacroModel capabilities.

The exercises contain only the information required for basic understanding and to complete
the task at hand. For more information about a particular MacroModel feature, see the Macro-
Model User Manual. To learn more about the command line MacroModel and MacroModel
operation codes, see the MacroModel Reference Manual.

Maestro comes with automatic context-sensitive help (Auto-Help), Balloon Help (tooltips), an
online help facility, and a set of manuals. For a tutorial introduction to the basic features of
Maestro, see the Maestro Tutorial. For information on using Maestro, see the Maestro online
help, the Maestro Overview, or the Maestro User Manual.
MacroModel 9.7 Quick Start Guide 1
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1.3 Preparing for the Exercises

To perform the exercises, you must have access to an installed version of Maestro 9.0 and
MacroModel 9.7. For installation instructions, see the Installation Guide.

The MacroModel installation contains the structure files used in the following exercises. In the
sections below, you will create a working directory and copy these files for your use. The
installation also contains sample input files, which you can use to run exercises without having
to complete all of the preceding exercises.

1.3.1 Creating a Working Directory and Copying Files

The first task to be done in preparation for the tutorial is to create a working directory to keep
all your input and output files.

UNIX:

1. Change to a directory in which you have write permission.

cd mydir

2. Create a directory by entering the command:

mkdir -p workdir

3. Copy the tutorial files into this directory:

cd workdir
cp $SCHRODINGER/macromodel-vversion/samples/QuickTopics/*.* .

Windows:

1. Open the folder in which you want to create the folder that serves as your working direc-
tory.

The default working directory used by Maestro is your user profile, which is usually set
to C:\Documents and Settings\username. To open this folder, do the following:

a. Choose Run from the Start menu.

b. Enter %USERPROFILE% in the Open text box and click OK.

2. Click Make a new folder under File and Folder Tasks.

You can also choose Folder from the New submenu of the File menu.

3. Enter a name for the folder.

If you want to create a folder inside this folder, repeat steps 1 – 3.
MacroModel 9.7 Quick Start Guide
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4. Open the folder that contains the tutorial files:

a. Choose Run from the Start menu.

b. Enter %SCHRODINGER% in the Open text box and click OK.

c. Open the MacroModel-vversion folder (version is the 5-digit MacroModel version
number), then open the samples folder inside that folder, then the QuickTopics
folder.

5. Select all the files in the QuickTopics folder, and drag them to the folder you created in
Step 3.

1.3.2 Starting Maestro

Once you have created the working directory you can start Maestro.

UNIX:

1. Set the SCHRODINGER environment variable to the installation directory:

This environment variable is also required to run MacroModel jobs.

2. If the current directory is not already your working directory, change to this directory.

cd workdir

3. Enter the command:

$SCHRODINGER/maestro &

The Maestro main window is displayed, and the working directory is Maestro’s current
working directory.

Windows:

• Double-click the Maestro icon on the desktop.

You can also use the Start menu. Maestro is in the Schrödinger submenu.

csh/tcsh:  setenv SCHRODINGER installation_path

bash/ksh:  export SCHRODINGER=installation_path
MacroModel 9.7 Quick Start Guide 3
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1.3.3 Setting the Maestro Working Directory

If you are running Maestro under Windows, or if you are using an existing Maestro session
under UNIX, you must change to the working directory that you created for the tutorial in
Section 1.3.1.

1. Choose Change Directory from the Maestro menu.

2. Navigate to the working directory and click Choose.
MacroModel 9.7 Quick Start Guide
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Chapter 2: Using Maestro
The exercises in this section present a quick tour of some aspects of the Maestro interface,
including the following:

• Importing a structure file
• Deleting portions of a Workspace structure
• Using the Find feature to locate particular structural elements
• Displaying, undisplaying, and labeling atoms and molecules
• Generating and displaying surfaces
• Defining atom sets for use when selecting atoms

You can find additional information about Maestro in the Maestro User Manual, and an intro-
duction to building, adjusting, displaying, and representing structures in the Maestro Tutorial.

Most of the exercises in this chapter use the structure in 1err.pdb, which you copied to your
working directory from the QuickTopics directory.

2.1 Importing a Structure

To display an existing structure in the Workspace, you must import the structure into the
current project. Follow the instructions below to import the 1err protein-ligand complex into
a named project. (You can work in a scratch project, but using a named project enables you to
organize the results of your calculations.)

1. Click the Save As toolbar button.

2. In the File name text box, enter 1err.prj, then click Open.

3. Click the Import structures button on the main toolbar.

The Import panel opens (see Figure 2.1). It should display the contents of your working
directory.
MacroModel 9.7 Quick Start Guide 5
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Figure 2.1. The Import panel.

You can also open the Import panel by choosing Project > Import Structures in the main
window or by choosing Table > Import > Structures in the Project Table panel.

4. Choose PDB from the Files of type option menu.

5. Select 1err.pdb from the list of files.

6. Click Open.

The Import panel closes, and a warning dialog box appears, but it isn’t critical for this
exercise. Click OK.

When Maestro imports a PDB file, problematic parts of imported structures, such as non-stan-
dard functional groups, are colored orange, red, green, or blue. For this exercise, it is not neces-
sary to correct the protein structure. However, when you begin to work on other proteins, you
may want to investigate and manually adjust marked portions. See Section 3.1.4 of the Maestro
User Manual for more information.
MacroModel 9.7 Quick Start Guide
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2.2 Identifying, Labeling, and Deleting Structure
Elements

This exercise demonstrates how to use Maestro’s display tools to inspect the protein-ligand
complex and delete parts of the structure that are not needed for a calculation.

The protein-ligand complex imported in the last exercise was obtained from the Protein Data
Bank repository. The structure contains crystallographic water molecules, which need to be
removed. Also, the structure is dimeric, and for most purposes only the monomer is required.

To label the water molecules with the PDB name:

1. In the Workspace, right-click on an atom in one of the outlying water molecules to spot-
center on the atom.

2. Zoom in on the water molecules by scrolling with the mouse wheel or by dragging with
the middle and right mouse buttons, until you have a good view of the water molecules.

3. Choose Composition from the Label picked atoms button menu.

The Atom Labels panel opens (see Figure 2.2)

4. Choose Molecules from the Label atoms pick menu.

5. In the Composition tab, select Residue name and clear all other selections.

6. In the Workspace, select one of the outlying water molecules of the structure to display its
label: HOH.

7. Close the Atom Labels panel.

To delete unwanted atoms:

1. Choose Waters from the Delete button menu.

All the water molecules are deleted.

2. Click the Fit to screen button.

The entire protein is now visible.
MacroModel 9.7 Quick Start Guide 7
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Figure 2.2. The Atom Labels panel showing the Composition tab.

3. Pause the pointer over various atoms in the protein until you find one that is in chain B.

Information on an atom is displayed in the status area at the bottom of the main window
when the pointer pauses over the atom, beginning with the chain name.

4. Choose Chains from the Delete button menu, and click on an atom in chain B.

The entire chain, including the ligand, is deleted, leaving chain A.
MacroModel 9.7 Quick Start Guide
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Figure 2.3. The Find Atoms panel.

2.3 Using the Find Atoms Panel to Identify Molecules

The imported structure contains three discrete molecules. Find and visualize the three separate
molecules with the Find Atoms panel:

1. From the Edit menu, choose Find to open the Find Atoms panel (see Figure 2.3).

2. Under Find types, choose Molecule.

3. Enter 1 in the Molecule number text box.

4. Select Mark principal atoms and Center.

5. Click Find.

6. Enter 2 in the Molecule number text box and click Find, to find molecule 2. Repeat for
molecules 3 and 4. Molecule 4 is the ligand.

7. When you have finished finding the molecules, clear all the options in the lower left of the
panel and close the Find panel.
MacroModel 9.7 Quick Start Guide 9
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2.4 Displaying and Undisplaying Atoms

By undisplaying atoms that do not contribute to active site functionality, you can more easily
examine the active site. Atoms can be displayed and undisplayed in the Workspace using the
toolbar, the Display/Undisplay Atoms panel, or by entering an undisplayatom command with
an appropriate Atom Specification Language (ASL) expression in the command input area.
Below are instructions for using the toolbar. For information on the other methods, see
Section 6.4 of the Maestro User Manual.

1. Choose Select from the Display only button menu.

The Atom Selection dialog box opens (see Figure 2.4).

2. In the Molecule tab, choose Molecule Number from the list on the left and enter 4 in the
Molecule Number text box.

Figure 2.4. The Atom Selection dialog box, Molecule tab.
MacroModel 9.7 Quick Start Guide
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3. Click Add, then click OK.

The ligand, molecule number 4, is displayed and the remaining atoms are undisplayed.

4. Choose Protein Backbone from the Also display button menu. Repeat for Protein Side
Chains and for Waters.

You have now redisplayed the entire protein. However, the crystallographic water molecules
have not been redisplayed because they were deleted, not undisplayed, in the exercise in
Section 2.2 on page 7.

You can also display residues that have atoms within a specified distance of the currently
displayed atoms. This is useful for displaying the part of a protein that is close to a ligand.

1. Choose Molecules from the Display only selected atoms button menu.

2. Click on an atom in the ligand to display only the ligand.

3. Choose +6 Å from the Display residues within N Å of currently displayed atoms button
menu.

For more complicated atom selections, you can use the Display/Undisplay Atoms panel
(choose Display/Undisplay Atoms from the Display menu).

4. Redisplay all atoms by choosing All from the Also display button menu.
MacroModel 9.7 Quick Start Guide 11
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2.5 Applying and Removing Atom Labels

You can apply labels to any atoms in the Workspace. You can also specify the label content,
label placement, and label appearance. In the exercise in Section 2.2 on page 7, you labeled
atoms with their PDB residue names. This exercise demonstrates how to apply and remove
various types of atom labels.

To apply atom labels:

1. Choose Composition from the Label picked atoms button menu.

The Atom Labels panel opens.

2. In the Composition tab, select Atom number, Atom type (MacroModel), and Formal
charge, and clear any other selections.

3. Under Label atoms, choose Molecules from the Pick menu.

4. In the Workspace, click on an atom in the ligand to label its atoms.

To remove atom labels:

1. Under Mode, select Remove (located at the top of the Atom Labels panel).

The Label atoms section is renamed Clear labels, to reflect the mode change.

2. Click Select in the Clear labels section.

The Atom Selection dialog box opens.

3. In the Atom tab, select Element from the list on the left, then select O from the Element
list in the center.

4. Click Add, then click OK to remove the labels for all oxygen atoms.

5. In the Atom Labels panel, click All in the Clear Labels section to remove all atom labels.

6. Close the Atom Labels panel.
MacroModel 9.7 Quick Start Guide
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2.6 Adjusting Bond Orders, Atom Types, and Formal
Charges

Most PDB structures derived from X-ray crystallography data do not have hydrogen atoms,
formal charges, or bond orders. When the structure is imported into Maestro, the conversion
utility uses templates for assigning multiple bonds in standard residues, but cannot do so for
ligands. Thus you need to explicitly add multiple bonds and formal charges to the ligands if
necessary. In this exercise you will learn how to perform these structural corrections manually,
however the Protein Preparation Wizard (see the Protein Preparation Guide) is designed to
automate many of these routine tasks. The tools for these tasks are found in the Build panel or
on the Build toolbar. The 1err ligand Raloxifene needs multiple bonds assigned, and the piperi-
dine nitrogen adjusted to be a four-coordinate, positively charged ammonium group. In this
exercise you will convert single bonds to double bonds and adjust the formal charges. In the
next exercise, the hydrogen atoms will be added.

1. Choose Molecules from the Display only selected atoms button menu and select an atom
in the ligand.

You can choose Molecule Number from the Color all atoms by scheme button menu, to
help distinguish the ligand.

2. If the molecule is not displayed in wire representation, choose Molecule from the Draw
bonds in wire button menu and pick an atom in the ligand.

3. Choose Element from the Color all atoms by scheme button menu.

4. Click Show/Hide the build toolbar toolbar button.

5. Click the Increment bond order button on the Build toolbar.
MacroModel 9.7 Quick Start Guide 13
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6. Click on the aryl C–C bonds that need to be converted to double bonds.

7. Click on the carbonyl C–O bond.

8. Click the Increment formal charge button on the Build toolbar.

9. Click on the nitrogen atom of the piperidine in the Workspace.

The formal charge of the nitrogen atom is now +1, and the atom type is automatically
adjusted. To check the formal charge, choose Formal Charge from the Label atoms button
menu. Choose Delete Labels from the Label atoms button menu to remove the label.

Maestro also provides a tool for automatic assignment of bond orders. To use it, choose Assign
Bond Orders from the Tools menu. Automatic assignments should always be checked, because
the rules that are used for the assignments cannot cover every possibility.

2.7 Adding Hydrogens to a United Atom Structure

Modern force fields use all-atom structures, and Maestro contains a facility to rationally add
the appropriate number of hydrogens to carbon atoms with approximately the correct geom-
etry. This exercise demonstrates how to use the tools in the Hydrogen Treatment panel to add
hydrogens to the structure in the Workspace.

1. From the Edit menu, choose Hydrogen Treatment.

2. Choose All-atom with No-Lp from the Treatments option menu (see Figure 2.5).

3. Under Modify hydrogen treatment, click All to add a full complement of hydrogens to the
original structure.

4. Close the Hydrogen Treatment panel.

You can also add hydrogen atoms with the Add hydrogens toolbar button. This button applies
the current hydrogen treatment to the selected atoms.

Now save the modified structure as a new entry in the project:

1. Click the Create entry from Workspace button in the toolbar.
MacroModel 9.7 Quick Start Guide
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Figure 2.5. The Hydrogen Treatment panel.

2. Enter 1err_htreat in the Entry name text box and click Create to update the Project
Table with the new entry.

2.8 Creating and Viewing Surfaces

Examining the surface of a molecule frequently leads to valuable insights. Maestro can create
several surface types. Surfaces can be rendered in different styles, color schemes, and transpar-
ency. Maestro surfaces are associated with project entries.

This set of exercises uses the 1err.prj project from the previous section. If you are starting
the tutorial at this point, follow the instructions in Section 2.1, Section 2.2, Section 2.6, and
Section 2.7 to set up the project for these exercises.

2.8.1 Creating a Molecular Surface of a Complex

Maestro can create molecular surfaces that represent solvent-accessible regions of an entry.
The molecular surface is a Connolly surface where a probe, typically with a radius of 1.4 Å, is
rolled over the molecule. The surface is defined by the contact of the probe’s outer radius and
the molecule’s van der Waals radius.

To generate a molecular surface for all atoms in the entry:

1. Open the Project Table panel (Open/Close Project Table toolbar button).

2. Click the In field for the 1err entry to include it in the Workspace.
MacroModel 9.7 Quick Start Guide 15
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Figure 2.6. The Molecular Surface panel.

3. Choose Molecular Surface from the Display > Surface in the main window.

The Molecular Surface panel opens (see Figure 2.6).

4. Enter MolSurf1 in the Name text box.

5. Under Atoms for surface display, choose Entries from the Pick menu.

6. Select Entry under Surface Context.

The surface context describes the atoms for which the surface is created. The surface dis-
play describes the atoms for which the resulting surface is displayed. You can change the
atoms for which the surface is displayed after surface generation by using the Limit fea-
ture, which you will do in the next exercise.

7. In the Workspace, select any atom in the entry.

8. Click Create Surface.

When the surface generation is complete, the surface is displayed in the Workspace and
the Manage Surfaces panel is displayed (see Figure 2.7).
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Figure 2.7. The Manage Surfaces panel.

You can experiment with the surfaces by doing any of the following:

• Generate the same surface with High image quality (give it a different name).

This calculation takes longer to generate, but the resulting surface has superior quality.
Also, the resulting high quality surface may be slower to rotate depending on your work-
station resources.

• In the Manage Surfaces panel, click Display Options and experiment with different styles
and color schemes.

The Partial Charge color scheme uses white until a calculation is performed. The struc-
ture was imported from a PDB record, which has no information about the fractional
atomic charges. Therefore, these must be calculated before Maestro can render the partial
charge values on the surface. To use the partial charges from the OPLS_2005 force field,
you can choose Assign Partial Charges from the Tools menu.

2.8.2 Limits to a Surface

Frequently the entire surface of an entry is not required. Instead of creating another surface
with a smaller subset of atoms, you can display a portion of a generated surface using the Limit
panel. This exercise demonstrates how to limit the surface generated in the previous exercise
from the entire entry to a smaller section of the entry.

1. In the table, click the V field of the MolSurf1 entry to display it.

2. Click Limit (in the lower portion of the Manage Surfaces panel) to open the Limit panel.

3. Enter mol.num 1 in the ASL text box.
MacroModel 9.7 Quick Start Guide 17



Chapter 2: Using Maestro

18
Figure 2.8. The Limit panel.

4. Click Apply to see the changes.

The surface is limited to the part that is generated for molecule number 1.

5. Click Select to open the Atom Selection dialog box.

6. In the Molecule tab, choose Molecule Number from the list and enter 2 in the Molecule
Number text box.

7. Click Add, then click OK.

8. In the Limit panel, click OK.

The surface is extended to include molecule number 2.

9. In the Manage Surfaces panel, deselect the Limit box for MolSurf1 to remove the surface
limit and redisplay the entire surface.

2.8.3 Generating a Surface for One Molecule in a Complex

An entry can be composed of multiple molecules, such as a co-crystallized receptor-ligand
complex. Maestro is capable of generating a surface using a subset of atoms in the entry. In this
example, you will use the 1err entry to create a surface of just the atoms near the binding site,
ignoring the ligand.

1. Choose Surface > Molecular Surface from the Display menu.

2. Enter MolSurf2 in the Name text box.

3. Under Atoms for surface display, click the Clear button to clear the ASL text box.

4. Click Select to open the Atom Selection dialog box.
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Figure 2.9. The Proximity dialog box.

5. In the Molecule tab, select Molecule Number from the list on the left and enter 4 in the
Molecule Number text box.

6. Click Add.

7. Click Proximity.

The Proximity dialog box opens (see Figure 2.9).

8. Under Proximity, select Within and Angstroms, and enter 5.0 in the text box.

9. Under Fill, select Residues and select Exclude source.

10. Click OK in the Proximity dialog box and in the Atom Selection dialog box.

11. In the Molecular Surface panel, under Surface context, select Molecule. Click Create Sur-
face.

The resulting surface clearly defines the topology of the binding site.

12. Close the Molecular Surface panel.

In the Manage Surfaces panel, you can click Display Options and color the surface by
partial charge or residue charge to visualize the electrostatics topology. You can also
change the style or transparency to see the atoms under the surface. When you are fin-
ished, close the Display Options panel and the Manage Surfaces panel.

13. Choose Surface > Undisplay All from the Display menu.

2.8.4 Creating a Map of the Binding Site

Maestro can be used to create “maps” of receptors. The map shows hydrophobic and hydro-
philic regions, and is a tremendous asset when manually docking or adjusting ligands in a
receptor. For this exercise, use the structure that was given the hydrogen treatment and map the
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region near the ligand. The atoms in the ligand do not need to be mapped, so they are excluded
from the structure to map, but the ligand makes a logical center to place the bounding box.

1. Open the Project Table panel (Open/Close project table toolbar button, choose Show
Table from the Project menu, or press CTRL+T).

2. Click the In field of the 1err_htreat entry to display it in the Workspace.

3. Choose Surface > Hydrophobic/philic from the Display menu.

The Hydrophobic/philic Surfaces panel opens.

4. In the Part of structure to map section, click Select.

The Atom Selection dialog box opens.

5. In the Molecule tab, choose Molecule Number from the list on the left and enter 3 in the
Molecule Number text box.

6. Click Add.

7. Click Proximity to open the Proximity dialog box.

8. Under Proximity, select Within and Angstroms, and enter 5.0 in the text box.

9. Under Fill, select Residues and select Exclude source.

Figure 2.10. The Hydrophobic/philic Surfaces panel.
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10. Click OK in the Proximity dialog box and in the Atom Selection dialog box.

11. In the Hydrophobic/philic Surfaces panel, under Bounding box, choose Molecules from the
Pick menu and select an atom in the ligand.

12. Enter 6.0 in the Box margin text box and choose Standard from the Grid Spacing option
menu.

13. Click Start to open the Start Job dialog box.

The Start dialog box opens. You can keep the default settings.

14. Click Start to start the job.

15. Enter sitemap1SHD in the Name text box.

16. Click Start to launch the job.

When the job finishes, the surface is displayed in the Workspace and the Manage Sur-
faces panel opens.

17. Close the Monitor panel.

18. In the Manage Surfaces panel, experiment with the transparency and the isovalue. For
example, select the philic surface in the table and enter -15.0 in the Isovalue text box
at the bottom of the panel. Enter -0.3 for the phobic isovalue.

19. When you have finished, close the Manage Surfaces panel and the Hydrophobic/philic
Surfaces panel.

2.9 Creating and Manipulating Atom Sets

Defining subsets of atoms can be useful for many analysis and visualization tasks as well as for
preparing MacroModel calculations. The Sets panel allows you to create and manipulate sets
using the full range of atom selection tools. Once created, sets can be used in the Atom Selec-
tion dialog box or from relevant Pick menus. Sets are saved within a Maestro project. To use
defined sets in another project, you can write them to a file using the Write button, then read
them into the new project using the Read button.

These exercises use the all-atom protein-ligand complex in 1err.mae:

1. Choose New from the Project menu and name the project 1errsets.

2. Import the structure from 1err_htreat.mae.

See Section 2.1 on page 5 for instructions on importing a structure.
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2.9.1 Defining an Atom Set by Selecting Atoms

With the contents of 1err_htreat.mae displayed in the Workspace, make a set that includes
all atoms in the ligand:

Set 1: Ligand

1. From the Tools menu, choose Sets

The Sets panel opens.

2. Click New (in the lower portion of the panel).

3. Enter ligand in the Set name text box, and click OK.

A new set is created, named ligand.

4. In the Sets panel, under Atoms for set, select Show markers (see Figure 2.11).

5. Choose Molecules from the Pick menu.

6. In the Workspace, select an atom in the ligand to define the ligand set.

If you need to identify the ligand, color the atoms by molecule number, or use the Find
Atoms panel described on page 9. If you do use Find Atoms, deselect Mark found atoms
once you have selected the desired atom.

Maestro highlights the atoms in the ligand set in green. Highlights are displayed as lines and
dots, or as boxes, depending on the molecular representation of the atoms and bonds.

Figure 2.11. The Sets panel.
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2.9.2 Defining an Atom Set with the Atom Selection Dialog Box

This exercise uses the Atom Selection dialog box to define more complex sets of atoms.

Set 2: Glycine residues

Create a set that contains all glycine residues in the structure:

1. Create a new set named glycine.

2. In the Sets panel, select Show markers.

3. Under Atoms for set, click Select.

The Atom Selection dialog box opens.

4. In the Residue tab, select Residue Type from the list on the left, then select GLY from the
Residue Type list in the center.

5. Click Add, then click OK.

You can switch between sets by selecting a set from the list at the top of the Sets panel.

Set 3: All residues with atoms within 5 Å of the ligand

Create a set containing the ligand and all atoms in complete residues within 5.0 Å of the
ligand:

1. Create a new set named lig+5A.

2. In the Sets panel, under Atoms for set, click Select.

The Atom Selection dialog box opens.

3. In the Set tab, select User-defined from the list on the left, then select ligand from the
User-defined list in the center, and click Add.

4. Click the Proximity button.

The Proximity dialog box opens.

5. Under Proximity, select Within and Angstroms, and enter 5.0 in the text box.

6. Under Fill, select Residues.

7. Click OK in the Proximity dialog box and in the Atom Selection dialog box.

The lig+5A set is defined.
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Set 4: Alpha carbons

Create a set of all the alpha-carbon atoms in the structure (atoms with a PDB atom type C-
alpha):

1. Create a new set named alphaC.

2. Under Atoms for set, click Select.

The Atom Selection dialog box opens.

3. In the Atom tab, select PDB type from the list on the left, then select CA from the PDB
type list in the center.

4. Click Add, then click OK to define the alphaC set.

2.9.3 Defining Atom Sets With Boolean Operations

New sets can be created from existing sets using Boolean operations. If you do not already
have the Sets panel displayed, open it from the Tools menu.

Set 5: NOT the ligand and NOT within 5 Å

Create a new set that contains all atoms that are neither in the ligand molecule nor within 5 Å
of the ligand:

1. Create a new set named frozen.

2. Under Atoms for set, click Select.

The Atom Selection dialog box opens.

3. In the Sets tab, select User-defined from the list on the left, then select lig+5A from the
User-defined list in the center.

4. Click Subtract.

5. Click OK to define the frozen set.

This set could be used to specify those atoms to be fixed or frozen in a MacroModel calcula-
tion.

Set 6: The ligand and all the glycine residues

Create a set containing the atoms in the ligand and in the glycine residues:

1. Create a new set named lig_or_gly.

2. Under Atoms for set, click Select.

The Atom Selection dialog box opens.
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3. In the Sets tab, select User-defined from the list on the left, then select ligand from the
User-defined list in the center.

4. Click Add.

5. In the Residue tab, select Residue Type from the list on the left, then select GLY from the
Residue Type list in the center.

6. Click Add, then OK to define the lig_or_gly set.

Set 7: All glycine residues in the lig+5A set

Create a set containing only atoms in the glycine residues within the lig+5A set:

1. Create a new set named lig_and_gly.

2. Under Atoms for set, click Select.

The Atom Selection dialog box opens.

3. In the Sets tab, select User-defined from the list on the left, then select glycine from the
User-defined list in the center.

4. Click Add.

5. In the Sets tab, select User-defined from the list on the left, then select lig+5A from the
User-defined list in the center.

6. Click Intersect, then OK to define the lig_and_gly set.

2.10 Filtering Structures: Sorting

It is often useful to identify subsets of a group of structures based on properties such as energy
or dihedral angle, which can be stored as properties in the Project Table. Energetic properties
are generated from the results of calculations and incorporated automatically into the Project
Table. In addition, geometric properties can be created from the Measurements panel and
applied to selected entries in the Project Table by selecting Create property for selected entries
when making the measurement selection.

Once the properties have been incorporated into the Project Table, you may use the Sort
facility to sort the structures in the Project Table by property value in increasing or decreasing
order.
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Figure 2.12. The Measurements panel showing the Dihedrals tab.

2.10.1 Generating Data

This exercise demonstrates how to create properties from measurements for a set of
conformers. The properties are automatically added to the Project Table.

1. Import the structures in Filter.mae, using the directions in Section 2.1 on page 5.

The structures are imported as a new entry group, and are selected.

2. Include one of the entries in the Workspace (click the In column).

3. Choose Tools > Measurements to open the Measurements panel.

4. In the Dihedrals tab, for Mode select Add.

5. Select Create property for selected entries (see Figure 2.12).
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6. Choose Atoms or Bonds from the Pick menu and select the four atoms or the three bonds
that define the torsion of interest.

When the torsion is defined, Maestro calculates the dihedral angle for each selected entry
and transfers the data to the Project Table as a new property.

7. Close the Measurements panel.

2.10.2 Filtering by Sorting

This exercise demonstrates how to sort the structures based on the dihedral angle generated in
the previous section.

1. In the Project Table, select the entries to be sorted.

You can use shift-click and control-click to select a range of items. Select the entries for
which you created properties in the previous section (these should already be selected).

2. Click the Sort button in the toolbar.

The Sort Project Table panel opens (see Figure 2.13)

3. In the Primary Key list, select a property such as the Dihedral property that you created.

If you want, you can also choose a secondary key.

4. Choose a sort order from the Order option menu.

Figure 2.13. The Sort Project Table panel.
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Figure 2.14. The New Plot dialog box.

5. Click Sort Selected Rows.

The entries in the Project Table are reordered based on the sort criteria.

You can then select a subset of entries with the desired range of properties. These structures
can be written to disk or investigated further.

6. When you have finished, close the Sort Project Table panel.
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3.1 Current Energy Calculations

Many types of energetic calculations are available using MacroModel. This section introduces
the MacroModel energetic panels and basic energetic parameters. These exercises calculate the
current molecular mechanics energy of a structure in gas phase, then in solution phase.

Before starting the calculations, import the substituted thymine structure from Ecalc.mae,
which you copied to your working directory in Section 1.3 on page 2. If you have not copied
these files, do so now. See Section 2.1 on page 5 for instructions on importing structures.

3.1.1 Calculating the Gas-phase Potential Energy

1. Choose MacroModel > Current Energy from the Applications menu

2. Choose Workspace (included entry) from the Use structures from option menu.

3. In the Potential tab, choose MMFFs from the Force Field option menu and choose None
from the Solvent option menu.

4. In the ECalc tab, choose Complete from the Energy Listing option menu.

5. Click Start.

The Start dialog box opens (see Figure 3.1).

6. Choose Replace existing entries from the Incorporate option menu.

7. Enter Ecalc in the Name text box.

Figure 3.1. The Start dialog box.
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Figure 3.2. The Current Energy panel showing the Potential tab.

8. Click Start to launch the job.

The energetic settings you selected instruct the Maestro job control facility to use the contents
of the Workspace as input to perform a current energy calculation and to replace the entry
corresponding to the Workspace with the structural results of the calculation. The settings also
instruct Maestro to use the MMFFs force field, not to use a solution model (since this is a gas
phase calculation), and to generate a complete listing of the molecular mechanics energy
terms.

When you start the calculation, the Monitor panel opens, and text describing the job status is
displayed in real time so that you can check the progress of the calculation. The job finishes
quickly, and the results are incorporated into the project. Since you selected Replace existing
entries, no new entries are added to the Project Table. Job files for this calculation are placed in
your working directory or the directory you chose for output files. The detailed energy listing
is written to a separate file, Ecalc-out.mmo.
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Figure 3.3. The Stretch panel.

3.1.2 Investigating Force Field Interactions

1. From the Tools menu, choose Force Field Viewer.

2. Click Browse, select Ecalc-out.mmo from the Files list, and click Open.

3. Click Stretch to open the Stretch panel (see Figure 3.3).

4. Click on a numbered pair in the list on the left to select a stretching interaction and dis-
play it in the Workspace with a magnifying glass icon.

5. To sort the stretching interactions, select Sort by Energy in the lower center portion of the
panel.

The list of stretching interactions is re-sorted so that the stretch with the lowest energy
(that is, the least strained atom pair) is at the top of the list.

6. To investigate a particular stretching interaction, choose Bond from the Define Stretch
pick menu and click on the desired bond in the Workspace.

7. To view stretching interactions by parameter quality, select the desired quality level from
the Show option menu. View relevant force field parameters by clicking Show force field.
This feature has limited utility for the BMFF force fields (MMFF and OPLS_2001).

The other panels opened from the Force Field Viewer panel are similar to the Stretch panel.
You can experiment with bond angle, electrostatic, and other parameters.

8. When you have finished, close the Stretch panel and the Force Field Viewer.
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9. Click the Clear Workspace button on the toolbar.

3.1.3 Calculating the Solution-phase Current Energy

1. Include the Ecalc entry in the Workspace.

2. Choose MacroModel > Current Energy from the Applications menu.

3. Choose Workspace (included entry) from the Use structures from option menu.

4. In the Potential tab, choose MMFFs from the Force Field option menu, and choose Water
from the Solvent option menu.

5. Enter 1.0 in the Dielectric constant text box.

For all calculations using the GB/SA solvation model, the constant dielectric treatment is
automatically used for the electrostatic part of the calculation. We recommend using a
low molecular dielectric constant (for example, 1.0).

6. Click the ECalc tab and choose None from the Energy Listing option menu.

7. Click Start to open the Start dialog box.

8. Under Incorporate, select Append new entries as a new group.

9. In the Name text box, type EcalcSolv.

10. Click Start to launch the job.

Because you selected the Append new entries option, when the job finishes, a new entry is
added to the Project Table with the total potential energy as a property. You can use the output
in the Monitor panel or in the output Ecalc.log and EcalcSolv.log files to examine the
details of the energies for the gas-phase and solution-phase calculations.

3.2 Energy Minimization

MacroModel energy minimizations are set up from the Minimization and Multiple Minimization
panels within Maestro. Minimization calculations can be performed on single structures and
multi-structure collections. In addition, for single structure calculations, the MacroModel
substructure facility can be used to select fixed and frozen atoms for the minimization of a
subset of atoms within a large structure.

For the next two exercises, you can either use the structure from Section 3.1.3 or import
Mini.mae from your working directory. The entry title is Ecalc. See Section 2.1 on page 5 for
instructions on importing structures.
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Figure 3.4. The Minimization panel showing the Mini tab.

3.2.1 Energy Minimization of a Single Structure

1. Choose MacroModel > Minimization from the Applications menu.

2. Choose Workspace (included entry) from the Use structures from option menu.

3. Click Start to open the Start dialog box.

4. Under Incorporate, select Append new entries individually.

5. In the Name text box, type Mini.

6. Click Start to launch the job.

The Monitor panel is displayed. An intermediate structure is displayed in the Workspace with
the atoms colored according to the energy gradient of the minimization at the time of moni-
toring. After job completion, the final minimized structure is incorporated into the project as a
new entry. If you wish to change the default minimization setting, click the Mini tab.
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3.2.2 Comparing Structural Results by Superposition

One useful way of comparing structural results is to superimpose them. Maestro provides tools
for superimposing molecules based on a selection of atoms. For a pair of molecules, you can
select the corresponding atoms manually, and Maestro superimposes them by minimizing the
RMSD of the selected atom distances. You can also select atoms in one structure using the
Atom Selection dialog box or ASL and use this set as the basis of superposition. The atom
specification is applied to each entry included in the Workspace. This is useful for groups of
conformers, but may have unintended results for non-conformers. Superposition is discussed
in detail in Section 9.3 of the Maestro User Manual. The following exercise demonstrates
superposition for two conformers.

1. Click the Clear Workspace button on the toolbar.

2. Open the Project Table panel (Open/Close project table toolbar button, choose Show
Table from the Project menu, or type CTRL+T).

3. Click the In column for the unminimized job input structure.

4. Control-click the In column for the minimized output structure.

5. Click the Tile entries button in the main window toolbar.

A dialog box is displayed warning that the coordinates of the entries may change. Click
Yes to proceed.

6. Choose Superposition from the Tools option menu.

The Superposition panel opens.

7. Click on the ASL tab.

8. In the Superimpose by ASL text box, enter the expression not atom.element H and
press RETURN. (see Figure 3.5).

The minimized structure is superimposed on the input structure, using only the non-
hydrogen (heavy) atoms.

9. Close the Superposition panel.
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Figure 3.5. The Superposition panel.

3.2.3 Energy Minimization of Multiple Structures

A collection of structures, either conformers or non-conformers, can be minimized in one
computation using the Multiple Minimization panel.

1. Click the Import structures button on the main toolbar.

The Import panel opens.

1. Click Options.

The Import Options dialog box opens.

2. Ensure that Import all structures is selected, and click Close.

The Import Options dialog box closes.
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3. In the Import panel, select MultMini.mae from the list of files, and click Open.

This file contains 10 small molecular structures, which are imported as a new group
named MultMini.

4. Open the Project Table panel.

5. Ensure that all 10 structures are selected in the Project Table.

See page 15 of the Maestro Overview for information on selecting entries.

6. Choose MacroModel > Multiple Minimization from the Applications menu.

7. Choose Project Table (selected entries) from the Use structures from option menu (see
Figure 3.6).

8. Click Start to open the Start dialog box.

Figure 3.6. The Multiple Minimization panel showing the Mult tab.
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9. Under Incorporate, select Replace existing entries.

10. In the Name text box, type MultMini.

11. Click Start to launch the job.

This job uses the selected entries as the input structure file and replaces the input entries in the
Project Table with the resulting energy minimized structures at the conclusion of the job.

For multi-conformer computations, you can eliminate duplicate minima and reduce the output
by using the tools in the Mult tab of the Multiple Minimization panel to define an energetic
window and identify comparison atoms.

3.2.4 Energy Minimization of a Substructure

The time required to minimize large structures can be drastically reduced by focusing on a
particularly important section of the structure and restraining, freezing, or ignoring the rest.
This exercise uses the protein-ligand complex from Section 2.1 to perform a substructure mini-
mization. The ligand and all residues within 5.0 Å of the ligand are freely minimized. The
atoms between 5.0 Å and 10.0 Å from the ligand are restrained, while the atoms between
10.0 Å and 15.0 Å from the ligand are frozen. The remaining atoms are ignored. For more
information on the Substructure facility, see Section 4.3.3 of the MacroModel User Manual.

1. Click the Clear Workspace button on the toolbar.

2. Import the structure in SubsMini.mae from your working directory.

The ligand in this complex is molecule number 4.

First, you will create an atom set for use in the definition of the substructures:

1. From the Tools menu, choose Sets.

The Sets panel opens.

2. Click New (in the lower portion of the panel).

3. Enter lig+5A in the Set name text box, and click OK.

A new set is created, named lig+5A.

4. In the Sets panel, under Atoms for set, select Show Markers.

5. Choose Molecules from the Pick menu.

6. In the Workspace, select an atom in the ligand.

If you need to identify the ligand, color the atoms by molecule number, or use the Find
Atoms panel described in Section 2.3 on page 9. If you do use Find Atoms, deselect Mark
found atoms once you have selected the desired atom.
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7. In the Sets panel, under Atoms for set, click Select.

The Atom Selection dialog box opens.

8. In the Molecule tab, click the Proximity button.

The Proximity dialog box opens.

9. Under Proximity, select Within and Angstroms, and enter 5.0 in the text box.

10. Under Fill, select Residues.

11. Click OK in the Proximity dialog box and in the Atom Selection dialog box.

The lig+5A set is now defined, and you can proceed to set up the job:

12. Choose MacroModel > Minimization from the Applications menu.

Figure 3.7. The Minimization panel showing the Substructure tab.
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13. Choose Workspace (included entry) from the Use structures from option menu.

14. In the Potential tab, choose OPLS_2001 from the Force field option menu.

15. In the Mini tab, enter 5000 in the Maximum iterations text box.

16. In the Substructure tab (see Figure 3.7), under Atoms for substructure, click Select.

The Atom Selection dialog box opens.

17. In the Set tab, select User-defined from the list on the left, then select lig+5A from the
User-defined list in the center.

18. Click Add, then click OK.

19. Select Show markers to highlight the atoms in the substructure.

This is the section of the structure that is minimized without restraints.

Next, you will define a shell of restrained atoms and another shell of frozen atoms.

20. Click New in the middle part of the Substructure tab below Shells (constrained and frozen
atoms).

21. Under Selected shell, select Complete residues.

22. Enter 5.0 in the Radius text box.

The restrained atoms are highlighted in orange in the Workspace.

23. Click New Shell again.

24. Under Selected shell, select Complete residues and Freeze Atoms.

25. Enter 5.0 in the Radius text box.

The frozen atoms are labeled in purple in the Workspace.

26. Click Start.

The Start dialog box opens.

27. Choose Append new entries individually from the Incorporate option menu.

28. Enter SubsMini in the Name text box.

29. Click Start to launch the job.

This job may take several minutes to finish.
MacroModel 9.7 Quick Start Guide 39



40
 MacroModel 9.7 Quick Start Guide



MacroModel Quick Start Guide
Chapter 4
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The goal of conformational searching is to locate the low-energy configurations of a molecular
structure. MacroModel includes a number of conformational searching algorithms as well as
mixed methods. This exercise first explores three standard conformational searches, then
explores searches with the ligand/protein system prepared earlier. The final search is a large-
scale low-mode search with another protein.

4.1 MCMM Search

The first conformational search is a Monte Carlo Multiple Minimum (MCMM), which gener-
ates trial conformations by randomly adjusting rotatable bonds.

1. Import MCMM.mae from your working directory.

2. Choose Applications > MacroModel > Conformational Search in the main window.

3. Choose Workspace (included entries) from the Use structures from option menu (see
Figure 4.1 on page 42).

4. In the Substructure tab, clear any previously defined substructures and shells.

5. In the CSearch tab, choose Torsional sampling (MCMM) from the Method option menu.

6. Deselect Multi-ligand and Perform automatic setup during calculation.

7. Click the Perform Automatic Setup button.

The parameters of the calculation should be displayed as markers on the structure. If they
are not, click the Display All Markers button in the Search Variables section. Many of the
variables define conformational comparisons, which govern how the generated structures
are compared and duplicates eliminated. They can be individually examined from the
parameter panels, which you open by clicking the respective parameter buttons in the
center of the tab. The defaults are sufficient for this exercise.

8. Enter 200 in the Maximum number of steps text box.

9. Click Start to open the Start dialog box.

10. Choose Append new entries as a new group from the Incorporate option menu.

11. Enter MCMM in the Name text box.
MacroModel 9.7 Quick Start Guide 41



Chapter 4: Conformational Searches

42
Figure 4.1. The Conformational Search panel showing the CSearch tab.

12. Click Start to launch the job.

This calculation takes a couple of minutes to finish. The Workspace is updated with the
current low-energy structure during the calculation.

The output structure file, MCMM-out.mae, contains all structures found within the specified
energetic window. The output log file, MCMM.log, includes a convenient listing of the molec-
ular mechanics potential energy of all the output structures.

4.2 Serial MCMM Conformational Search

Serial MCMM conformational searches perform an MCMM conformation search on each
input structure, with MCMM parameters that are set up automatically (by means of an AUTO

opcode in the command file).
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1. Import Serial.mae from your working directory.

2. In the Project Table, select the three imported entries.

3. Choose Applications > MacroModel > Conformational Search from the main window.

4. Choose Project Table (selected entries) from the Use structures from option menu.

5. In the CSearch tab, choose Torsional sampling (MCMM) from the Method option menu.

6. Select Multi-ligand.

Perform automatic setup during calculation (at the top of the panel) is automatically
selected and dimmed because it is mandatory for this type of calculation.

7. Enter 100 in the Number of steps text box.

8. Click Start to open the Start dialog box.

9. Choose Append new entries as a new group from the Incorporate option menu.

10. Enter SerialMCMM in the Name text box.

11. Click Start to launch the job.

The output structures are incorporated into the Project Table when the conformational
search is finished as a group named SerialMCMM.

The serial_split utility can be used to divide the results of a serial search into individual
output files for the individual input structures. See Section 18.7 of the MacroModel User
Manual for more information.

4.3 Serial Low-Mode Search

Low-mode searching explores the low-frequency eigenvectors of the system to generate new
conformations. A low-mode calculation does not require the designation of ring structures and
variable torsion angles.

1. Import Serial.mae from your working directory.

2. In the Project Table, select the three imported entries.

3. Choose Applications > MacroModel > Conformational Search from the main window.

4. Choose Project Table (selected entries) from the Use structures from option menu.

5. In the CSearch tab, choose Low-mode sampling from the Method option menu and select
Multi-ligand.

6. Enter 100 in the Number of steps text box.
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7. Click Start to open the Start dialog box.

8. Choose Do not incorporate from the Incorporate option menu.

9. Enter SerialLMOD in the Name text box.

10. Click Start to launch the job.

The output structure file, SerialLMOD-out.mae, contains a collection of minimized configu-
rations for each input structure.

4.4 Ligand Conformational Search with a Frozen
Receptor

In Section 3.2.4, a protein-ligand complex was minimized using the OPLS_2001 force field.
There are multiple approaches to performing a subsequent conformational search on the
complex. Two methods are demonstrated in the following two sections.

This first exercise demonstrates how to perform a substructure conformational search on the
protein/ligand complex, keeping the protein frozen. The MCMM method is used for the ligand.

To set up the job:

1. Import the minimized structure LigandMCMM.mae from your working directory.

2. Display the structure in the Workspace.

3. Choose Applications > MacroModel > Conformational Search from the main window.

4. Choose Workspace (included entries) from the Use structures from option menu.

5. In the Potential tab, choose OPLS_2005 from the Force field option menu and choose
None from the Solvent option menu.

6. In the CSearch tab, choose Torsional sampling (MCMM) from the Method option menu.

7. Deselect Multi-ligand.

8. For a shorter computation, enter 200 in the Maximum number of steps text box.

To set conformational search parameters manually for the ligand:

Note that this setup would not be adequate for a complete search of conformational space.

1. Display only the ligand molecule (see Section 2.4 on page 10 for instructions).

2. Center the ligand in the Workspace by right-clicking on a central atom in the ligand.
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Figure 4.2. The Comparison Atoms panel.

3. Click the Fit to screen button on the main toolbar.

4. In the CSearch tab of the Conformational Search panel, deselect Perform automatic setup
during calculation.

5. Click Reset All Variables.

6. From the Search variables option menu, choose Comparison Atoms, then click Edit, to
open the Comparison Atoms panel (see Figure 4.2).

The procedure below selects the non-hydrogen atoms of the ligand.

7. Under Define comparison atoms, click Select to open the Atom Selection dialog box.

8. In the Molecule tab, select Molecule Number from the list and type 4 in the Molecule
Number text box (or click on the molecule in the Workspace), then click Add.

9. In the Atom tab, select Element from the list on the left, then select H from the Element
list, and click Subtract to remove the hydrogen atoms from the selection set.

10. Click OK, then close the Comparison Atoms panel.

11. In the CSearch tab, from the Search variables option menu choose Torsion Rotations,
then click Edit, to open the Torsion Rotations panel (see Figure 4.3).
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Figure 4.3. The Torsion Rotations panel (left) and the Molecule Trans/Rot panel (right).

Torsion rotations indicate the torsions that are randomly rotated during the search. All
non-trivial C-C and N-C bonds (except amide torsions) could be selected. It is only nec-
essary to choose the second and third atoms of the torsion.

12. Choose Atoms from the Pick menu and select a few torsions from the structure in the
Workspace, (e.g., 1770/1771, 1779/1780, 1789/1790).

13. Close the Torsion Rotations panel.

14. In the CSearch tab, from the Search variables option menu choose Molecule Trans/Rot,
then click Edit, to open the Molecule Trans/Rot panel (see Figure 4.3).

The Molecule Trans/Rotation feature identifies molecules that are to be rotated and trans-
lated relative to each other. Only the ligand needs to be specified in this example.

15. In the Workspace, select any atom in the ligand. Use the default minimum and maximum
values.

16. Close the Molecule Trans/Rot panel.

To freeze the protein and start the job:

This section uses the Substructure facility to freeze the receptor atoms that are within 6 Å of
the ligand. MacroModel automatically ignores any remaining atoms in the computation.
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1. Redisplay all atoms by double-clicking the Display only selected atoms toolbar button.

2. In the Substructure tab of the CSearch panel, clear any previously defined substructures
and shells.

3. In the Freely moving atoms (substructure) section, enter the following in the ASL text
box:

mol.n 4

4. Click New in the Shells (constrained and frozen atoms) section.

5. Select Complete residues and enter 6.0 in the Radius text box.

6. Select Freeze atoms.

Maestro colors the frozen atoms orange; the remainder are ignored in the computation.

7. Click Start.

8. In the Start dialog box, choose Append new entries as a new group from the Incorporate
option menu.

9. Enter LigandMCMM in the Name text box.

10. Click Start to launch the job.

This computation will take one to three hours, depending on your computer. When the
calculation is complete, the output structures are incorporated as a group named
LigandMCMM.

11. Use the ePlayer to view the different low-energy orientations.

For more information on the ePlayer, see Section 8.6 of the Maestro User Manual.

4.5 Substructure Conformational Search with
Automatic Setup

The last exercise demonstrated a computation in which the ligand was manually assigned
Monte Carlo conformational search parameters while the entire receptor was held frozen. This
exercise demonstrates a modified conformational search that enables increased receptor flexi-
bility, using Perform Automatic Setup to define the MCMM search variables.

The steps below prepare a substructure conformational search calculation in which the receptor
is divided into freely moving, fixed, and frozen regions. Computations using substructures use
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less resources than full receptor simulations. Automatic Setup recognizes substructures and
assigns the MCMM conformational search parameters only to functional groups in the
substructure, and not to those in the restrained or frozen part of the structure.

To set up the job:

1. Import the structure in SubsAuto.mae from your working directory.

2. Display the structure in the Workspace.

3. Choose Applications > MacroModel > Conformational Search from the main window.

4. Choose Workspace (included entries) from the Use structures from option menu.

5. In the Potential tab, choose OPLS_2001 from the Force field option menu and choose
None from the Solvent option menu.

6. In the Mini tab, enter 5000 in the Maximum iterations text box.

To set up the substructure and shells that define moving, fixed, and frozen atoms:

In this example, the freely-moving portion includes the ligand, as well as all residues within
3 Å of the ligand.

1. Click the Substructure tab.

2. In the Freely moving atoms (substructure) section, choose Molecules from the Pick menu
and click on an atom in the ligand in the Workspace.

3. Enter 3.0 in the Expand to atoms within radius of text box and select Complete residues.

You could achieve the same result by using the Atom Selection dialog box to select mole-
cule number 4 and the atoms within 3 Å, or by entering the following expression in the
ASL text box:

fillres within 3 (mol.num 4)

4. Under the Shells list, click New.

5. In the Selected shell section, select Complete residues and enter 2.0 in the Radius text
box.

This is the shell of fixed atoms, with harmonic constraints of 200 kJ/mol Å2 applied.

6. Click New.

7. In the Selected shell section, select Complete residues and Freeze atoms and enter 2.0 in
the Radius text box.

This is the shell of frozen atoms.
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The moving, fixed, and frozen regions have now been defined and are indicated in the Work-
space as white, orange, and purple regions.

To set up the search method and search variables:

In this example, you will use the automatic setup features to define the MCMM conformational
search variables. You can set up variables either for the entire moving region (the substructure)
or only for the ligand molecule. Atoms in the fixed or frozen atom regions do not have confor-
mational search variables assigned to them when using Perform Automatic Setup.

8. In the CSearch tab, choose Torsional sampling (MCMM) from the Method menu.

9. Ensure that Multi-ligand is not selected.

10. Do one of the following:

• Select Perform Automatic Setup during calculation to assign MCMM parameters for
the freely-moving substructure region automatically during the calculation.

• Deselect Perform Automatic Setup during calculation, click Reset All Variables, then
click Perform Automatic Setup to assign MCMM parameters to the entire freely-
moving region.

• Enter the following command in the command input area of the main window to
assign MCMM parameters to the ligand only:

autosetup mol.n 4

11. For a shorter computation, change the value in the Number of steps text box to 200.

To enter the job information and start the job:

1. Click Start.

2. In the Start dialog box, choose Append new entries as a new group from the Incorporate
option menu.

3. Enter SubsAuto in the Name text box.

4. Click Start to launch the job.

The sample files included in the distribution have conformational search variables defined only
for the ligand.
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4.6 Large-Scale Low-Mode Conformational Search

The large-scale low-mode (LLMOD) conformational searching routine is a unique method for
generating candidate conformations of very large structures, including full proteins. Combina-
tions of low-frequency vibrational modes are used to produce candidate structures. These
modes represent simultaneous, concerted conformational changes in the structure.

Specialized applications of LLMOD include protein loop optimization, homology model
refinement, and fully flexible docking for induced-fit modeling. In addition, LLMOD-gener-
ated conformations can be used for subsequent rigid docking studies.

For this exercise, you will use the crambin structure 1crn, which is contained in the file
LLMOD.mae in your working directory. This is a 14-amino acid sequence. Large proteins can
take multiple hours to complete the LLMOD conformational search. Solvation should gener-
ally be used for LLMOD searches, but it is not used in this exercise in order to speed the
computation.

The example structure has been minimized with OPLS_2001 without solvation. Any structure
used in an LLMOD conformational search must be initially minimized to a low gradient with
the same force field and solvation treatment that will be used in the conformational search.

1. Import the protein in LLMOD.mae from your working directory.

2. Choose Applications > MacroModel > Conformational Search from the main window.

3. Choose Workspace (included entries) from the Use structures from option menu.

4. In the Potential tab, choose OPLS_2001 from the Force field option menu.

5. In the Constraints tab, clear any previously set constraints by clicking Reset All in both
the Constrain section and the Freeze section.

6. In the Substructure tab, clear any previously defined substructures and shells.

7. In the CSearch tab, select Large scale low-mode sampling from the Method option menu.

8. Enter 100 in the Maximum number of steps text box.

9. In the Mini tab, enter 1.00 in the Convergence threshold text box.

10. Click Start to open the Start dialog box.

11. Choose Append new entries as a new group from the Incorporate option menu.

12. Enter LLMOD in the Name text box.

After the job finishes, Maestro incorporates the structures into the Project Table. Depending on
the size of the structure, the computation may take some time to complete.
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MacroModel has a range of other capabilities than those already encountered. This chapter
provides exercises to illustrate some of these capabilities:

• Embrace—ligand binding to a receptor
• Molecular dynamics
• Energy profiles as a function of dihedral angles
• Free energy calculations using MINTA
• Partition coefficients between two solvents
• Cluster analysis of structures

5.1 Embrace

Embrace is an automated routine that uses a collection of individual ligands, each pre-posi-
tioned with respect to a given receptor. Embrace automatically performs energetic calculations
on each complex formed from the receptor and the individual ligands. Embrace can work in
two modes—interaction mode and energy difference mode. In the first, the receptor and the
ligand are individually treated as separate sets, and only the energy components between sets
are evaluated and recorded. The Embrace energy difference mode reports the minimized
energy of both the individual ligand and receptor subtracted from the minimized energy of the
complex. It is also possible to perform Embrace calculations using conformational searches.

Embrace calculations can be accelerated by using substructures with constraints applied to
atom positions. The substructure need only include elements of the protein, not any ligands.
This exercise demonstrates how to import a receptor and a group of ligands, and import a
substructure and run the calculations with constraints.

1. Import Embrace.mae from your working directory.

If you are not sure how to import a structure, use the directions in Section 2.1 on page 5.

This file contains a single protein and four pre-positioned ligands. Only the first structure,
the receptor, is displayed in the Workspace.

2. In the Project Table, select all of the entries.

The structural input to an Embrace calculation must contain the receptor first, followed
by the pre-positioned ligands. In Maestro, the receptor must be the first selected entry.
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Figure 5.1. The Embrace Minimization panel showing the Embrace tab.

3. Choose Applications > MacroModel > Embrace Minimization from the main window.

4. In the Potential tab, choose OPLS_2001 from the Force field option menu and choose
None from the Solvent option menu.

5. In the Mini tab, enter 1000 in the Maximum Iterations text box.

6. Click the Embrace tab (see Figure 5.1).

7. Under Source of ligands, select Selected entries.

8. Under Receptor, select First selected entry.

9. Under Association energy mode, select Interaction energy mode.

10. Under Structures saved, select Complexes only.
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11. In the Substructure tab, click the Read .sbc file button in the lower right corner of the
panel and select Embrace.sbc from your working directory.

The atoms in the structure are highlighted: white markers for the substructure, orange
markers for shell 1, and purple markers for shell 2.

12. Click Start to open the Start dialog box.

13. Choose Append new entries from the Incorporate option menu.

14. Enter Embrace in the Name text box.

15. Click Start to launch the job.

This calculation may take 10 minutes. When the calculation is complete, the results are placed
in a table at the end of the Embrace.log file and are incorporated into the Project Table.

5.2 Molecular Dynamics

Molecular dynamics calculations simulate molecular movement over time using Newton’s
equations of motion. In this exercise, you will run an MC/SD dynamics calculation.

In the MC/SD simulation, an initial minimization is performed to ensure that the structure is at
a minimum on the potential energy surface. Geometric structural parameters can be monitored
over the course of the dynamics simulation, and structures can be sampled during the simula-
tion at constant intervals. Since MC/SD uses Monte Carlo methods, it is also necessary to
define the Monte Carlo parameters.

1. Import the structure in MCSD.mae from your working directory.

This structure has been minimized to a low gradient with MMFFs in the gas phase.

2. Choose Applications > MacroModel > MC/SD from the main window.

3. Choose Workspace (included entry) from the Use structures from option menu.

4. In the Potential tab, choose MMFFs from the Force field option menu and choose None
from the Solvent option menu.

5. In the Constraints tab, clear any previously set constraints by clicking the Reset All button
in both the Constrain section and the Freeze section.

6. In the Substructure tab, click the Clear button in both the Atoms for substructure section
and in the Shells section, to clear any previously defined substructures and shells.

7. In the Shells section, click Delete Shells until all shells are deleted.
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Figure 5.2. The MC/SD panel showing the MC/SD tab.

8. In the Mini tab, enter 5000 in the Maximum iterations text box and enter 0.002 in the Con-
vergence threshold text box.

These parameters are required for the initial minimization.

9. In the Monitor tab, enter 10 in the Number of structures to sample text box.

You can use the buttons in this tab if you want to conduct additional structural
monitoring.

10. In the Dynamics tab, choose Stochastic dynamics from the Method option menu, and
choose Nothing from the SHAKE option menu.

SHAKE is not recommended for MC/SD simulations.

11. In the MCSD tab, click Perform Automatic Setup (see Figure 5.2).

To view the selected torsions, click Torsion Rotations in the middle of the panel.
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12. Click Start to open the Start dialog box.

13. Choose Append new entries as a new group from the Incorporate option menu.

14. Enter MCSD in the Name text box.

15. Click Start to launch the job.

The ten sampled structures are incorporated into the Project Table at the completion of
the computation.

After incorporation, you can view the sample trajectory using Maestro’s ePlayer. The incorpo-
rated structures should already be selected in the Project Table. Click the Play forward button in
the Project Table toolbar to view the trajectory in the Workspace.

For more information on the ePlayer, see Section 8.6 of the Maestro User Manual.

5.3 Creating Energy Profiles From Coordinate Scans

A contour diagram describing the molecular mechanics potential energy of a structure, relative
to the value of either one or two coordinates (distances, angles, or dihedrals), can be generated
with MacroModel. These exercises demonstrate how to produce a contour diagram describing
the variation in energy of a molecule with respect to rotation of two dihedral angles.

5.3.1 Performing a Coordinate Scan Calculation

1. Import the structure in Ddrive.mae from your working directory.

2. Choose Applications > MacroModel > Coordinate Scan from the main window.

The Coordinate Scan panel opens.

3. Choose Workspace (included entry) from the Use structures from option menu.

4. In the Potential tab, choose MMFFs from the Force Field menu and choose None from the
Solvent option menu.

5. In the Substructure tab, click the Clear button to clear any substructure.

6. Click Delete Shell enough times to clear all shells.
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Figure 5.3. The Coordinate Scan panel showing the Scan tab.

7. From the Label atoms button menu on the main toolbar, choose Atom Number.

All atoms in the workspace are labeled with their corresponding atom number.

8. In the Scan tab of the Coordinate Scan panel, under Define coordinate to scan, choose
Dihedral from the Coordinate type option menu.

9. Choose Atoms from the Pick menu (see Figure 5.3).

10. In the order listed, pick the atoms in the Workspace that define the two angles: 1, 14, 15,
16, and 6, 25, 26, 27. (Use the middle mouse button to rotate the structure, if necessary.)

11. Click Start to open the Start dialog box.

12. Choose Do not incorporate from the Incorporate option menu.

13. Enter Ddrive in the Name text box.
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Figure 5.4. The 2D Plot panel.

14. Click Start to launch the job.

Two files are produced:

• Ddrive-out.grd contains the energetic results of the calculation
• Ddrive-out.mae contains the structural output.

5.3.2 Analyzing the Results of the Coordinate Scan

You can create a contour diagram of Ddrive-out.grd from the 2D Plot panel (see Figure 5.4):

1. From the Tools menu, choose 2DPlot.

2. Click Open and select Ddrive-out.grd from your working directory.

3. Click Open.

The interactive plot is displayed in the plotting area.

4. When you have finished examining the plot, close the 2D Plot panel and choose Close
from the Project menu.
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5.4 MINTA Prediction of Free Energy

MINTA is a powerful tool for estimating free energies from individual conformations or
collections of conformations. Many common methods for estimating the free energy of a
conformation do so based on a single point in conformation space (i.e., the exact coordinates
provided). A key feature of MINTA is that an integration is performed over the normal modes
for each conformation in order to accurately estimate the free energy of the local potential
minimum as a whole. As with other free energy methods, performing multiple MINTA calcu-
lations and taking the appropriate differences among them can yield estimates of binding free
energies. Note that while MINTA and MacroModel are tightly coupled, additional licensing is
needed to run MINTA.

This exercise uses MINTA to estimate the free energy of the substituted thymine structure
based on the results of the conformational search in Section 4.1 on page 41.

Figure 5.5. The MINTA panel showing the MINTA tab.
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The MCMM computation contained multiple structures in the output file. The entire set of
conformers can be used as input to MINTA, or, to shorten the computation, a subset of the
lowest energy structures can be used.

1. Import the structures in Minta.mae from your working directory.

2. Select all entries in the Project Table, or just a subset of the lowest energy structures.

3. Choose Applications > MacroModel > MINTA from the main window.

4. Choose Project Table (selected entries) from the Use structures from option menu (see
Figure 5.5 on page 58).

5. In the Potential tab, choose the same force field that you used to perform the conforma-
tional search. (The Minta.mae file was generated using MMFFs.)

6. Click Start to open the Start dialog box.

7. Choose Append new entries as a new group from the Incorporate option menu.

8. Enter Minta in the Name text box.

9. Click Start to launch the job.

The MINTA free energy and other information is written at the end of the .log file and is
included as a set of properties in the Project Table.

5.5 Partition Coefficient Between Two Solvents

MacroModel can estimate the logarithm of the partition coefficient of a solute between two
solvents. The GB/SA parameterized solvents available are water, octanol, and chloroform.
Multiple solutes can be used as input by selecting entries in the Project Table. The input struc-
tures are minimized in each solvent, and the resulting difference in solvation energies is used
for the logP calculation.

The octanol-water partition coefficient, logP(o/w), is often used as a measure of molecular
hydrophobicity and other environmental parameters. In this exercise, you will run a logP(o/w)
calculation from Maestro.

1. Import the structure in LogP.mae from your working directory.

2. Choose Applications > MacroModel > Multiple Minimization from the main window.

3. Choose Workspace (included entries) from the Use structures from option menu.

4. In the Potential tab, choose MMFFs from the Force field option menu and select Octanol
from the Solvent option menu.
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Figure 5.6. The Multiple Minimization panel showing the Mult tab.

5. In the Mini tab, enter 5000 in the Maximum iterations text box and enter 0.02 in the Con-
vergence threshold text box.

6. In the Mult tab, select LogP estimation and choose Water from the Secondary solvent
option menu (see Figure 5.6).

7. Click Start to open the Start dialog box.

8. Choose Append new entries as a new group from the Incorporate option menu.

9. Enter logP in the Name text box.

10. Click Start to launch the job.

The Monitor panel is displayed. When the job is finished, the logP(o/w) value is displayed
in the monitoring window.
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5.6 Analysis of Molecular Structure With XCluster

XCluster is a powerful structural clustering tool that uses molecular similarity as the clustering
criterion. XCluster can be run from Maestro, using a set of conformers contained in the Project
Facility as input and comparison data selected with Maestro’s picking tools. The calculations
are run and the results visualized with the XCluster interface, which is automatically started by
Maestro.

Note: This exercise cannot be performed under Windows.

1. Import the structures from XCluster.mae from your working directory.

The structures are imported as an entry group named XCluster, and are selected in the
Project Table.

2. Choose XCluster from the Applications menu.

3. Choose Project Table (selected entries) from the Use structures from option menu (see
Figure 5.7).

4. Under Cluster by, select Torsional RMS.

5. Under Define comparison torsions, choose Atoms from the Pick menu and select atoms in
the Workspace for the torsions you want to examine, such as 2-1-14-15.

Figure 5.7. The XCluster panel.
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6. Click Start to open the Start dialog box.

7. Enter XCluster in the Name text box.

8. Click Start to launch the job.

9. When the analysis is finished, use the visualization tools by choosing Clustering Statis-
tics, Distance Map, or Clustering Mosaic from the Visualize menu.

Descriptions and examples of the usage of these functions can be found in the MacroModel
XCluster Manual and in the original literature article.
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Schrödinger software is distributed with documentation in PDF format. If the documentation is
not installed in $SCHRODINGER/docs on a computer that you have access to, you should install
it or ask your system administrator to install it.

For help installing and setting up licenses for Schrödinger software and installing documenta-
tion, see the Installation Guide. For information on running jobs, see the Job Control Guide.

Maestro has automatic, context-sensitive help (Auto-Help and Balloon Help, or tooltips), and
an online help system. To get help, follow the steps below.

• Check the Auto-Help text box, which is located at the foot of the main window. If help is
available for the task you are performing, it is automatically displayed there. Auto-Help
contains a single line of information. For more detailed information, use the online help.

• If you want information about a GUI element, such as a button or option, there may be
Balloon Help for the item. Pause the cursor over the element. If the Balloon Help does
not appear, check that Show Balloon Help is selected in the Maestro menu of the main
window. If there is Balloon Help for the element, it appears within a few seconds.

• For information about a panel or the tab that is displayed in a panel, click the Help button
in the panel, or press F1. The help topic is displayed in your browser.

• For other information in the online help, open the default help topic by choosing Online
Help from the Help menu on the main menu bar or by pressing CTRL+H. This topic is dis-
played in your browser. You can navigate to topics in the navigation bar.

The Help menu also provides access to the manuals (including a full text search), the FAQ
pages, the New Features pages, and several other topics.

If you do not find the information you need in the Maestro help system, check the following
sources:

• Maestro User Manual, for detailed information on using Maestro
• Maestro Command Reference Manual, for information on Maestro commands
• Maestro Overview, for an overview of the main features of Maestro
• Maestro Tutorial, for a tutorial introduction to basic Maestro features
• MacroModel User Manual, for detailed information on using MacroModel
• MacroModel Reference Manual, for information on MacroModel commands
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• MacroModel Frequently Asked Questions pages, at
https://www.schrodinger.com/MacroModel_FAQ.html

• Known Issues pages, available on the Support Center.

The manuals are also available in PDF format from the Schrödinger Support Center. Local
copies of the FAQs and Known Issues pages can be viewed by opening the file
Suite_2009_Index.html, which is in the docs directory of the software installation, and
following the links to the relevant index pages.

Information on available scripts can be found on the Script Center. Information on available
software updates can be obtained by choosing Check for Updates from the Maestro menu.

If you have questions that are not answered from any of the above sources, contact Schrödinger
using the information below.

E-mail: help@schrodinger.com
USPS: Schrödinger, 101 SW Main Street, Suite 1300, Portland, OR 97204
Phone: (503) 299-1150
Fax: (503) 299-4532
WWW: http://www.schrodinger.com
FTP: ftp://ftp.schrodinger.com

Generally, e-mail correspondence is best because you can send machine output, if necessary.
When sending e-mail messages, please include the following information:

• All relevant user input and machine output
• MacroModel purchaser (company, research institution, or individual)
• Primary MacroModel user
• Computer platform type
• Operating system with version number
• MacroModel version number
• mmshare version number

On UNIX you can obtain the machine and system information listed above by entering the
following command at a shell prompt:

$SCHRODINGER/utilities/postmortem

This command generates a file named username-host-schrodinger.tar.gz, which you
should send to help@schrodinger.com. If you have a job that failed, enter the following
command:

$SCHRODINGER/utilities/postmortem jobid
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where jobid is the job ID of the failed job, which you can find in the Monitor panel. This
command archives job information as well as the machine and system information, and
includes input and output files (but not structure files). If you have sensitive data in the job
launch directory, you should move those files to another location first. The archive is named
jobid-archive.tar.gz, and should be sent to help@schrodinger.com instead.

If Maestro fails, an error report that contains the relevant information is written to the current
working directory. The report is named maestro_error.txt, and should be sent to
help@schrodinger.com. A message giving the location of this file is written to the terminal
window.

More information on the postmortem command can be found in Appendix A of the Job
Control Guide.

On Windows, machine and system information is stored on your desktop in the file
schrodinger_machid.txt. If you have installed software versions for more than one
release, there will be multiple copies of this file, named schrodinger_machid-N.txt,
where N is a number. In this case you should check that you send the correct version of the file
(which will usually be the latest version).

If Maestro fails to start, send email to help@schrodinger.com describing the circumstances,
and attach the file maestro_error.txt. If Maestro fails after startup, attach this file and the
file maestro.EXE.dmp. These files can be found in the following directory:

%LOCALAPPDATA%\Schrodinger\appcrash

On Windows XP and Windows 2000, %LOCALAPPDATA% is not set by default, but should
correspond to %USERPROFILE%\Local Settings\Application Data.
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